Solved: poor acceleration problem?

Check engine light was steady “ON” on dash.Getting car module scanned showed error P0141. Error P0141 is for oxygen sensor problem. If the air filter is plugged it can cause increased fuel consumption and in severe cases it can cause running problems. The O2 sensor code you have is for the heater inside the coil. In order for the O2 sensor to work properly you need to have the sensor hot. In the past the engine would run in a predetermined fuel map until the O2 sensor was hot and started working.

At that time it would switch and add/subtract fuel by using the O2 sensor. That few minutes or so when this was happening (engine running off fuel map before O2 sensor was hot) was causing increased emissions and to stop this they started making O2 sensors that have a heater inside. It’s similar to a toast coil. It’s a wire inside that gets really hot as soon as the engine is started to reduce the time the O2 isn’t working. What usually happens is that wire inside breaks and the computer doesn’t see any change on that wire when it’s sending current too and then it sends a code and turns on the check engine light.

But in case if you still get error Check engine light on dash then, I would take off the cat. after the header and check for a plugged exhaust. You should be able to see light through it. Looks like a honeycomb just smaller cells. It should not look melted or anything and should not have chucks of anything falling out or anything. If it looks good then you need to check the header for blockage. I think you may have a blockage. Another thing you can do is put a vacuum gauge on the intake manifold and watch the needle after you rev the engine up and let it idle. It will drop down on the gauge if it’s got a blocked exhaust.

Leave a Reply

Your email address will not be published. Required fields are marked *